NaaLaa Forum
new and lost - Printable Version

+- NaaLaa Forum (http://www.naalaa.com/community)
+-- Forum: NaaLaa (http://www.naalaa.com/community/forumdisplay.php?fid=1)
+--- Forum: Questions and discussions (http://www.naalaa.com/community/forumdisplay.php?fid=3)
+--- Thread: new and lost (/showthread.php?tid=178)



new and lost - aliensoldier - 09-01-2019

Hello, I am Spanish and I don't know almost any English, just single words and little else, I am writing using the google translator, if there is an error in the translation I am sorry but it is the translator's fault. Angel



I've been learning to use gamemaker and construct 2 for a few months, but recently I found Naalaa and I found it interesting.

I was looking at the documentation but since I know almost nothing English I didn't understand anything, and then I looked at the examples but I didn't understand anything either because I know very little about programming.

I have searched for tutorials and video tutorials but I have not found anything, I would like to learn how to use naalaa but I don't know where to start or how to do it, any suggestions or help. Smile


RE: new and lost - aliensoldier - 09-03-2019

I'll try.

If you find a tutorial step by step in pdf tell me.

I would like to know how this naalaa is today, there are regular updates.

There is thought to improve it or to modernize it.


RE: new and lost - kcfb - 09-03-2019

(09-03-2019, 03:00 PM)aliensoldier Wrote: I'll try.

If you find a tutorial step by step in pdf tell me.

I would like to know how this naalaa is today, there are regular updates.

There is thought to improve it or to modernize it.

Hi,
For videos, try Marcus Johansson's pages on Youtube:
https://www.youtube.com/user/NaaLaaCreator/videos

This platformer tutorial I found useful:
https://www.youtube.com/watch?v=T4R8n9URiWU
...but do try the others too.....

Regards - Kevin


RE: new and lost - aliensoldier - 09-19-2019

Hello again.
Is there any way to change the colors of the text and background of the ide of naalaa?.

I would like to have a theme like the obsidian theme, which is a pretty nice color theme.


RE: new and lost - Marcus - 09-20-2019

(09-19-2019, 01:49 PM)aliensoldier Wrote: Hello again.
Is there any way to change the colors of the text and background of the ide of naalaa?.

I would like to have a theme like the obsidian theme, which is a pretty nice color theme.

If you look in the folder c:/n6, there should be a file config.txt. You can edit the values in that file to change sourcecode related colors (and fonts).


RE: new and lost - Marcus - 09-20-2019

[Image: theme.jpg]

Here's an example. I've attached the config.txt file.


RE: new and lost - aliensoldier - 09-20-2019

Thanks Marcus. Smile

I tried the processes and I was wrong to finish the process with a separate end proc, the ide was blocked and the fan of my computer began to move very fast.


Can this problem occur very often?


RE: new and lost - Marcus - 09-20-2019

(09-20-2019, 10:13 AM)aliensoldier Wrote: Thanks Marcus. Smile

I tried the processes and I was wrong to finish the process with a separate end proc, the ide was blocked and the fan of my computer began to move very fast.


Can this problem occur very often?

Never seen that. I shall have a look and fix it Smile


RE: new and lost - aliensoldier - 09-20-2019

Try this code.
Code:
wln "saludos"
proc saludar
wait keydown

procedure saludar()
    wln "hola amigo"
end proc

With this code the program crashes and does not let me close it until after a while, and the fan starts to move very fast, as I have told you.


RE: new and lost - Marcus - 09-21-2019

(09-20-2019, 06:33 PM)aliensoldier Wrote: Try this code.
Code:
wln "saludos"
proc saludar
wait keydown

procedure saludar()
    wln "hola amigo"
end proc

With this code the program crashes and does not let me close it until after a while, and the fan starts to move very fast, as I have told you.

Yeah, should be "endproc", one word. But it's terrible that it hangs, shouldn't even compile without an error. As you found out, there seems to be some issue when the compiler searches for "endproc". I'll fix it when I get the time. Sorry Smile