The following warnings occurred:
Warning [2] Undefined property: MyLanguage::$archive_pages - Line: 2 - File: printthread.php(287) : eval()'d code PHP 8.0.28 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/printthread.php(287) : eval()'d code 2 errorHandler->error_callback
/printthread.php 287 eval
/printthread.php 117 printthread_multipage

NaaLaa Forum
N7 version 22.02.25b - Printable Version

+- NaaLaa Forum (
+-- Forum: NaaLaa (
+--- Forum: Announcements (
+--- Thread: N7 version 22.02.25b (/showthread.php?tid=944)

Pages: 1 2

N7 version 22.02.25b - Marcus - 02-25-2022

It may not look that much different. But this version of NED uses a new GUI library that I've been working on for a while. Lots of bugs from the old NED have been fixed, and you can now resize the window as you like, switch between a light and dark theme and change the font size with a click. It saves your settings and remembers and re-opens the last n7 file you edited. Next I will add support for workspaces and tabs for having multiple files opened at the same time.

[Image: ngui.jpg]

The GUI library is included (the compiler will always find it in the libs folder), but it's far from complete, lacks comments and examples and is 100% undocumented. But you might guess how it works by looking at the source code of ned.


* Replaced ned with a new IDE using ngui
* Added the ngui (wip) library
* Added the 'draw ellipse" command
* Added the 'exists' function

* Rewrote most parts of asm.c
* Added some bytecode optimizations
* Added the 'draw vraster' and 'draw hraster' commands
* Added the 'assert' command
* Added the 'asm' and 'endasm' commands for inline bytecoding
* Fixed a bug where 'copy' did absolutely nothing
* Added support for dynamic window size

* Added the 'save image' command
* Added the 'save font' and 'load font' commands and the 'loadfont' function
* Fixed some garbage collector issues

* Added the command 'gc' to force garbage collecting
* Fixed a memory issue during deep copying of tables
* Fixed a bug in the 'fwait' function
* % is now a modulo rather than remainder operator

* Added support for scrolling with mousewheel in ned
* Added support for mousewheel through mousebutton(2)
* Added a pause (wait for key press) after runtime errors in console applications
* Added a message box for runtime errors in win32 applications

* First beta release.

RE: N7 version 22.02.25b - johnno1956 - 02-26-2022

Thanks Marcus. I am a big fan of dark themes, but this version is quite nice... I like it. Great job!

RE: N7 version 22.02.25b - Marcus - 02-26-2022

Just click on the "Night mode" checkbox and things will get cozy Smile

I updated the zip just now, without chaning the version. Realized that the mouse wheel wasn't working, but it should be fine now.

Edit Updated it once more. Got the mouse wheel working but forgot to update the line number column when using it. It's 2 in the morning, better get some sleep.

RE: N7 version 22.02.25b - johnno1956 - 02-26-2022

I just found one *tiny* problem... The game that I had converted, using the previous version of N7, compiles and runs but does not produce a display... I have to dash out for a while... Will look into it when I get back...

Cool... Night Mode checkbox found... Nice.

RE: N7 version 22.02.25b - Marcus - 02-26-2022

(02-26-2022, 01:19 AM)johnno1956 Wrote: I just found one *tiny* problem... The game that I had converted, using the previous version of N7, compiles and runs but does not produce a display... I have to dash out for a while... Will look into it when I get back...

Cool... Night Mode checkbox found... Nice.


Does ned/n7 and the program exist on the same disk/volume?

Does it work if you run it through the old ned (ned_pre_ngui.exe)?

I made some changes (safe, I thought) in the new ned when he runs a compiled program. Maybe I messed up the current working directory, so that your program can't find its assets.

RE: N7 version 22.02.25b - johnno1956 - 02-26-2022

I created a new directory for the latest version. I ran the previous version of NED from within the new directory and N7 ran (obviously minus the gui). I hope that helps?

I was finished working modifying the old N6 "Shoot 'em UP" to run on N7... that's when I found your message..

RE: N7 version 22.02.25b - Marcus - 02-26-2022

This is so weird, me confused.

When new ned starts, it tries to load the most recently used file. But this means that the current working directory (cwd) is the directory of n7 and not that of the loaded file (when you use a file dialog to load a program, the file dialog changes the cwd). So when I first added this feature I experienced what (I think) you're describing. If I let n7 load the most recent file and tried to compile and run it, all I got was a black screen - the program was launched with the wrong cwd and couldn't find it's images. I solved it by adding the /d parameter to the windows command line 'start' command. In the 'Run' function of ned.n7 It changed from:

start "" "c:\my folder\my game.exe"


start /d "c:\my folder\" "" "c:\my folder\my game.exe"

(The "" part is supposed to be there, but maybe it should be right after 'start', and maybe the last \ shouldn't be in the path following \d ... but I doubt this is what's causing the problem.)

And this fixed the problem, so that's what the new ned uses.

Now I've tested all kinds of weird situations here. I put the source code and the assets of an n7 program on another volume (an usb stick) while having n7 and ned on my hard drive. I added white space in paths and filenames, I let n7 load the program using the most recent-file feature et.c. But the program always compiles and runs fine fore me.

Would you mind taking a screenshot of ned after trying to compile and run the program, so that I can see if there's something weird in the path (output window)? Totally respect you if you, for any reason, don't want me to see directory names on your computer though Smile What I want to know is if you see the FULL path of the programs you load in the output-window.

Does it fail with all programs you're trying to compile and run? Do you get the same result if you:
1) Open the program through ned's file menu
2) Let ned open the program as the most-recent file (close ned after having loaded a file through the menu and then start ned again - the file should automatically load)
3) Start ned by clicking on an n7 file (if you have associated n7 files with ned)

I'm terribly sorry for all the questions. But if it fails for you, it will certainly fail for some others too (bad first time experience, for sure).

RE: N7 version 22.02.25b - kcfb - 02-26-2022

Fantastic - thanks Marcus. Seems to be working fine here.

I have tried a few scenarios:
1 - N7 installation folder on local C drive loading programs from the local C drive
2 - N7 installation folder on local C drive loading programs from a networked Z drive
3 - N7 installation folder on networked Z  drive loading programs from a networked Z drive

The programs run fine in all scenarios with me.

I only found one tiny issue. This happened only once, when I loaded an N7 file into NED for the very first time. Ned was in the standard default window size, and the issue was that the first 15 characters or so were off screen on the command window - screenshot attached:

I could use the left arrow key to move the missing characters into the window, and the issue did not re-occur when I re-loaded NED.

Really like the new themes, and the automatic loading of the last used file. And looking forward to having multiple tabs - at the moment I need to have 2 or 3 instances of NED running as I like to have 2 or 3 files open at a time.

Many thanks - Kevin.

RE: N7 version 22.02.25b - johnno1956 - 02-26-2022

First test: Using a USB stick as an 'isolated' drive. I ran all of my programs (1945, Santa and Shootemup). All of them loaded, compiled and ran. The "output" of NED indicates that each program is "Executing" but no external window or game screen.

Second test: Did exactly the same, using version N7_220211, via the USB... They all loaded, compiled and ran. All games created a display. All games played as designed.

I must inform you that you should not take my problems as an indication that your program is faulty. Case in point. Kevin's ran ok. We ran the same N7. The only difference would be that I run with Linux Mint and use Wine to execute any and all Windows-based programs. Wine is not 100% accurate at the best of times...

Conclusion: N7_220211 runs fine. I will continue to use it as long as I can. Concentrate on your Windows users. I can wait for a Linux version down the track... then maybe the Raycaster and Tilemap... No pressure, right! lol

RE: N7 version 22.02.25b - Marcus - 02-26-2022

Alright, but I'm 99% sure it's the 'start' command failing, because that's the only change I've made in this part. I'll skip the /d flag in next version and change the current working directory when an n7 file is loaded instead.