Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tilemap potential bug?
#1
As you know, I have began tackling a Mario type game, using the tilemap editor and may have come across a minor problem.

I added a "coin" to the current collection of tiles. 16x16 transparent background. Using the mouse and moving the coin around the screen everything looked normal. I can "see" the map showing through the transparent "corners" of the coin. But, placing the coin on the map, changes the coin's background to white. "Not a problem". Used Gimp to change the coin background to magenta [255, 0, 255] and replaced the coin in the tileset. Reloaded the map. Coin appeared among the other tiles with the magenta background. Placed the coin on the map. Coin positioned with magenta background. Removed the coin from the map. Set colorkey to magenta. Magenta disappeared from the coin in the tileset. Placed the coin on the map. Coin was placed with a white background.

This problem did not occur with the other tiles as the other tiles did not have transparency.

I hope I am making sense...

J
May your journey be free of incident.
Live long and prosper.
Reply
#2
(10-24-2022, 08:27 AM)johnno1956 Wrote: As you know, I have began tackling a Mario type game, using the tilemap editor and may have come across a minor problem.

I added a "coin" to the current collection of tiles. 16x16 transparent background. Using the mouse and moving the coin around the screen everything looked normal. I can "see" the map showing through the transparent "corners" of the coin. But, placing the coin on the map, changes the coin's background to white. "Not a problem". Used Gimp to change the coin background to magenta [255, 0, 255] and replaced the coin in the tileset. Reloaded the map. Coin appeared among the other tiles with the magenta background. Placed the coin on the map. Coin positioned with magenta background. Removed the coin from the map. Set colorkey to magenta. Magenta disappeared from the coin in the tileset. Placed the coin on the map. Coin was placed with a white background.

This problem did not occur with the other tiles as the other tiles did not have transparency.

I hope I am making sense...

J

There is only one layer in a map. So if you make a cel in the tiles image transparent (using the alpha channel or a colorkey) and put it on the map, you see what is behind the map, which in this case is the white background color of the window. So I think it's working as it should, but I'm not sure Smile

Any reason for making the coin background transparent instead of letting it use the background color used by the other tiles?
Reply
#3
My ability, or in this case in-ability, to convey accurately the problem that I have, is somewhat left wanting....

I need to run a few tests to either confirm or disprove a theory. I will get back to you as soon as I can.

My testing of a theory involved using a VM to run N7 and N7tme. This was to either confirm or refute a Linux/Wine thing...
Result was that there was not any difference.

I am left with the conclusion that the cause of the problem is actually me... Using transparency within the tileset AND including the background colour when using CLS has rendered the coin, as well as all the other tiles, as they should.

My apologies for seeing errors where there were none and for wasting your time... Sad

J
May your journey be free of incident.
Live long and prosper.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)